$re = '/:(?=[^<>:]+>)/m';
$str = '<ns:Documents>
<ns:Owner>
<ns:data>полезные:данные:которые:могут:быть разделены двоеточием</ns:data>
</ns:Owner>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);