re = /.*\//m
str = '/fileserver/thumbnail/THUMBNAIL.jpg
/img/list/btn_img02.gif
/img/list/cont_img06.gif
/img/list/line02.gif
/comment.asp
/img/foot/foot_logo.gif
/img/foot/btm_img01.gif
/img/foot/btm_img02.gif
/img/foot/btm_img03.gif
/img/list/cont_img07.gif
/img/list/cont_img08.gif
/img/list/btn_img03.gif'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end