using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[`]\K | (?<=\G) (?>{.*?}|[^`]) \K [^{}`]+";
string input = @"`{string} with {exluded} words 12 nums`
`string {with} {exluded} words 12 nums`
""quoted {string} with {exluded} words and 12 nums""
""quoted string {with} exluded {words} and {12} nums""";
RegexOptions options = RegexOptions.IgnorePatternWhitespace | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}