#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)a(r|i|ir|ri|irr|rri|rr)(ba|b|ab)" & @CRLF & _
""
Local $sString = "ariba" & @CRLF & _
"airba" & @CRLF & _
"arba" & @CRLF & _
"arib" & @CRLF & _
"airb" & @CRLF & _
"arriba" & @CRLF & _
"arrba" & @CRLF & _
"airrba" & @CRLF & _
"airab" & @CRLF & _
"ariab" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")