$re = '/^\s*([A-Z]{3})\s*=\s*([0-9.]+)\s*([A-Z]{3})\s*$/m';
$str = 'USD = 6.4CNY
CNY = 0.13 EUR
EUR = 0.87 GBP
GBP = 89.4 INR';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);