$re = '/0([1][89]|[2-9][0-9])/';
$str = '018 099 017 021 018 019 020 024 099 009999999';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);