#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:image:\/\/)(?<Thumnail>.+)\/transform\?size=thumb$"
Local $sString = "image://%2fhome%2fkeana%2fPictures%2fWallpapers%2fpawel-czerwinski-6lQDFGOB1iw-unsplash.jpg/transform?size=thumb"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")