$re = '/^(\w|(?<!\.)\.)+(?<!\.)\.(testnet|near)$/m';
$str = 'example.testnet
sub.ex.testnet
something.testnet
shouldnotendwithperiod.testnet.
space should fail.testnet
touchingDotsShouldfail..testnet
example.near
exa..ef.near';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);