package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\p{Sc}`)
var str = `Vous pouvez payer en €uro en £ivre ou en ¥en. Et même en ₿itcoin !`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}