$re = '/\p{Sc}/';
$str = 'Vous pouvez payer en €uro en £ivre ou en ¥en. Et même en ₿itcoin !';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);