use strict;
my $str = '123456789';
my $regex = qr/([0-9]{5})[0-9]*/mp;
my $subst = '$1****';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";