const regex = /H\d*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('H\\d*', 'g')
const str = `C40H51N11O19 - 51 hydrogens
C40H789N11O19 - 789 hydrogens
C2HO - 1 hydrogen
HO3 - 1 hydrogen
CO2 - no hydrogens (empty)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}