use strict;
my $str = 'C40H51N11O19 - 51 hydrogens
C40H789N11O19 - 789 hydrogens
C2HO - 1 hydrogen
HO3 - 1 hydrogen
CO2 - no hydrogens (empty)';
my $regex = qr/H\d*/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}