# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"H\d*"
test_str = ("C40H51N11O19 - 51 hydrogens\n\n"
"C40H789N11O19 - 789 hydrogens\n\n\n"
"C2HO - 1 hydrogen\n"
"HO3 - 1 hydrogen\n\n"
"CO2 - no hydrogens (empty)")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.