Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Regular
Expressions
101
Regular
Expressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
^(?!.*\bjack\b.*\bjack\b)(?!.*\bjames\b.*\bjames\b)(?=.*\bjames\b)(?=.*\bjack\b).*$
/
gm
Input 1
1
New
hi jack here is james hi james here is jack hi james jack here is jack james hi jack james here is james jack hi jack jack here is jack james hi james james here is james jack hi jack jack jack here is james