const regex = new RegExp('(?<=\\|\\s?(?>opening|ending|insert)\\s?=.*)([^,\\n]+),?\\s?', 'gm')
const str = `|opening= MAGIC TIME, Test
| ending = MAGIC TIME, Test, Test2
|insert = MAGIC TIME, Test, Test2`;
const subst = `{{track|p=$1}}\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);