#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!none@|na@)\w+(\.\w+)*@(\w+\.)+\w{2,4}$"
Local $sString = "bob@bob.com" & @CRLF & _
"na@bob.com" & @CRLF & _
"none@bob.com" & @CRLF & _
"naa@bob.com" & @CRLF & _
"nonee@bob.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")