using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!none@|na@)\w+(\.\w+)*@(\w+\.)+\w{2,4}$";
string input = @"bob@bob.com
na@bob.com
none@bob.com
naa@bob.com
nonee@bob.com";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}