# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(M)([0-9])$/\10\2/gm;t' <<< "2020M6
2020M10"