import Foundation
let pattern = #"(M)([0-9])$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
2020M6
2020M10
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\10\2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)