package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\w+)-(.+:\/\/.+(?:[.:].+)+(?:\/))?([\w.-]+)\/([\w.-]+)@(.+)`)
var str = `protobuf-protocolbuffers/protobuf@v3.15.2
mongodb-https://github.com/mongodb/mongo-php-driver@v1.9
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}