$re = '/(?<!\\\\)"/';
$str = 'Meine_kleine_Farm
MEINE "KLEINE" FARM
Meine kleine "Farm"
Korrekt \\"escaped\\" hier
halb "korrekt\\" escaped
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);