$re = '/(?:\'s)?[^\p{L}\-\d_]+|\.+$/m';
$str = 'Infographic phishing\'s awareness and $prevention (updated).+!@=¨$\'^^;,:';
$subst = "-";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;