re = /SOL:(\d{4})\s+(.*)\s+EXPOZITIE (\w{1,2}) */m
str = '* SOL:1201 тут слова строки текста , EXPOZITIE ST * '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end