using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"SOL:(\d{4})\s+(.*)\s+EXPOZITIE (\w{0,2}) *";
string input = @"* SOL:1201 тут слова строки текста , EXPOZITIE ST * ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}