$re = '/\b(\S+)(?:\s+\1\b)+/i';
$str = 'A very very very dirty dog Dog';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;