re = /"(field)"(\s*:\s*")/m
str = '"field": {}
"field" : ""
"field":1'
subst = '"$1_text"$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result