// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)"(field)"(\s*:\s*")"#).unwrap();
let string = "\"field\": {}
\"field\" : \"\"
\"field\":1";
let substitution = "\"$1_text\"$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}