$re = '/.*: (?P<year>\d{4})/m';
$str = 'January - May 2022';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);