using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^:\s]++(?!:)";
string substitution = @"Line:$0";
string input = @"1 : A
2 : B
3 : C
1
2
3
1:A
11:A";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}