$re = '/^[^:\s]++(?!:)/m';
$str = '1 : A
2 : B
3 : C
1
2
3
1:A
11:A';
$subst = "Line:$0";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;