import Foundation
let pattern = #"([^a-z]+[a-z]+)([^a-z]+[a-z]+)([^a-z]+[a-z]+)([^a-z]+[a-z]+)(?=[^a-z]*)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"modeland istoria in tiparele fluide ale artei si despre frumusetea adevarului integral"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$2$4$3$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)