use strict;
my $str = '25
321
54500
78545515201';
my $regex = qr/(\d)()(?=(\d{3})+(?!\d))/p;
my $subst = '$1 $2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";