#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([A-Z0-9\/\(\)]*)\s?[0-9]*\s[A-Z\']*\s\b(ROAD|LANE|STREET|AVENUE|PARADE|WAY|DRIVE|HIGHWAY|PLACE)\b"
Local $sString = "407/82 HAY STREET " & @CRLF & _
"A314/1 DEMETER STREET " & @CRLF & _
"51/14 HASSALL STREET " & @CRLF & _
"(LOT1022) 60 LACERTA ROAD " & @CRLF & _
"LOT1149 KELLY STREET " & @CRLF & _
"(LOT1003) KELLY STREET " & @CRLF & _
"(LOT1010) 65 ORION ROAD " & @CRLF & _
"(LOT1109) 80 LACERTA ROAD " & @CRLF & _
"(LOT1013) 59 ORION ROAD " & @CRLF & _
"(LOT1017) 28 MULUMULUNG STREET" & @CRLF & _
"(LOT1021) 62 LACERTA ROAD " & @CRLF & _
"A106/5 ADONIS AVENUE " & @CRLF & _
"C122/5 ADONIS AVENUE " & @CRLF & _
"17 DONCASTER STREET " & @CRLF & _
"E108/3 ADONIS AVENUE " & @CRLF & _
"103/46 WALKER STREET " & @CRLF & _
"C118/5 ADONIS AVENUE " & @CRLF & _
"13 GOODISON PARADE " & @CRLF & _
"305/6 BAY STREET " & @CRLF & _
"A507/18 O'DEA AVENUE "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")