import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([A-Z0-9\\/\\(\\)]*)\\s?[0-9]*\\s[A-Z\\']*\\s\\b(ROAD|LANE|STREET|AVENUE|PARADE|WAY|DRIVE|HIGHWAY|PLACE)\\b";
final String string = "407/82 HAY STREET \n"
+ "A314/1 DEMETER STREET \n"
+ "51/14 HASSALL STREET \n"
+ "(LOT1022) 60 LACERTA ROAD \n"
+ "LOT1149 KELLY STREET \n"
+ "(LOT1003) KELLY STREET \n"
+ "(LOT1010) 65 ORION ROAD \n"
+ "(LOT1109) 80 LACERTA ROAD \n"
+ "(LOT1013) 59 ORION ROAD \n"
+ "(LOT1017) 28 MULUMULUNG STREET\n"
+ "(LOT1021) 62 LACERTA ROAD \n"
+ "A106/5 ADONIS AVENUE \n"
+ "C122/5 ADONIS AVENUE \n"
+ "17 DONCASTER STREET \n"
+ "E108/3 ADONIS AVENUE \n"
+ "103/46 WALKER STREET \n"
+ "C118/5 ADONIS AVENUE \n"
+ "13 GOODISON PARADE \n"
+ "305/6 BAY STREET \n"
+ "A507/18 O'DEA AVENUE ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}