import Foundation
let pattern = #"^([A-Z0-9\/\(\)]*)\s?[0-9]*\s[A-Z\']*\s\b(ROAD|LANE|STREET|AVENUE|PARADE|WAY|DRIVE|HIGHWAY|PLACE)\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
407/82 HAY STREET
A314/1 DEMETER STREET
51/14 HASSALL STREET
(LOT1022) 60 LACERTA ROAD
LOT1149 KELLY STREET
(LOT1003) KELLY STREET
(LOT1010) 65 ORION ROAD
(LOT1109) 80 LACERTA ROAD
(LOT1013) 59 ORION ROAD
(LOT1017) 28 MULUMULUNG STREET
(LOT1021) 62 LACERTA ROAD
A106/5 ADONIS AVENUE
C122/5 ADONIS AVENUE
17 DONCASTER STREET
E108/3 ADONIS AVENUE
103/46 WALKER STREET
C118/5 ADONIS AVENUE
13 GOODISON PARADE
305/6 BAY STREET
A507/18 O'DEA AVENUE
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)