const regex = /(?:^fix(?:es)?(?:\s+bugzilla)(?:\s+(?:issues?|bugs?))?\s+(#?\d+(?:[\s,\+&and]+#?\d+)*))|
(?:bugzilla\s+(?:(?:issues?|bugs?)\s+)?(#?\d+(?:[\s,\+&and]+#?\d+)*))/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^fix(?:es)?(?:\\s+bugzilla)(?:\\s+(?:issues?|bugs?))?\\s+(#?\\d+(?:[\\s,\\+&and]+#?\\d+)*))|
(?:bugzilla\\s+(?:(?:issues?|bugs?)\\s+)?(#?\\d+(?:[\\s,\\+&and]+#?\\d+)*))', 'ig')
const str = `Fix bugzilla issue 12564: add std.range.walkBack `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}