re = /(?:^fix(?:es)?(?:\s+bugzilla)(?:\s+(?:issues?|bugs?))?\s+(#?\d+(?:[\s,\+&and]+#?\d+)*))|
(?:bugzilla\s+(?:(?:issues?|bugs?)\s+)?(#?\d+(?:[\s,\+&and]+#?\d+)*))/i
str = 'Fix bugzilla issue 12564: add std.range.walkBack '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end