import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<n>(?:@(?<org>[a-z0-9-~][a-z0-9-._~]*)\\/)?(?<pkg>[a-z0-9-~][a-z0-9-._~]*))(?:@(?<v>[-a-z0-9><=_.^~*| ]+))?(?<p>\\/[^\\r\\n]*)?$";
final String string = "react-icons@4.4.0/\n"
+ "@heroicons/react@latest/package.json\n"
+ "react\n"
+ "react/hello\n"
+ "react@1\n"
+ "react/\n"
+ "reaction@1.1.1/index.js\n"
+ "react@*\n"
+ "react@>1.2|| <= 1.*\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}