#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.*\bKeyWord2\b)|\G.*?\K\bKEYWORD1\b"
Local $sString = "The KeyWord2 before one KEYWORD1 here" & @CRLF & _
"The KEYWORD1 before one KeyWord2 here" & @CRLF & _
"The KEYWORD1 before KeyWord2 then KEYWORD1 and KEYWORD1 again" & @CRLF & _
"The KeyWord2 before KEYWORD1 and KEYWORD1 again" & @CRLF & _
"The KEYWORD1 before one KeyWord99 here" & @CRLF & _
"The KEYWRD before one KeyWord2 here" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")