using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.*\bKeyWord2\b)|\G.*?\K\bKEYWORD1\b";
string input = @"The KeyWord2 before one KEYWORD1 here
The KEYWORD1 before one KeyWord2 here
The KEYWORD1 before KeyWord2 then KEYWORD1 and KEYWORD1 again
The KeyWord2 before KEYWORD1 and KEYWORD1 again
The KEYWORD1 before one KeyWord99 here
The KEYWRD before one KeyWord2 here
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}