re = /^(?=.*\bKeyWord2\b)|\G.*?\K\bKEYWORD1\b/m
str = 'The KeyWord2 before one KEYWORD1 here
The KEYWORD1 before one KeyWord2 here
The KEYWORD1 before KeyWord2 then KEYWORD1 and KEYWORD1 again
The KeyWord2 before KEYWORD1 and KEYWORD1 again
The KEYWORD1 before one KeyWord99 here
The KEYWRD before one KeyWord2 here
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end