using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(.+?)(?: (.+?)=(.+?))*?>.*?<\/\1>";
string substitution = @"";
string input = @"<w c5=""NP0"" hw=""michael"" pos=""SUBST"">Michael </w>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}