re = /<(.+?)(?: (.+?)=(.+?))*?>.*?<\/\1>/m
str = '<w c5="NP0" hw="michael" pos="SUBST">Michael </w>'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result