import Foundation
let pattern = #"SessionStartTime=(?<date>[^|]*)\|LogEventId=(?<LogEventId>[^|]*)\|action=(?<action>[^|]*)\|login=(?<login>[^|]*)\|account=(?<tag1>[^|]*)\|sip=(?<sip>[^|]*)\|UserName=(?<tag2>[^|]*)\|group=(?<group>[^|]*)\|responsecode=(?<responsecode>[^|]*)\|result=(?<result>[^|]*)\|dname=(?<dname>[^|]*)\|sessiontype=(?<sessiontype>[^|]*)\|(?<vendorinfo>[^ ]*)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive, .allowCommentsAndWhitespace])
let testString = #"""
SessionStartTime=2/21/2021 6:36:37 PM|LogEventId=1898|action=Successful login with database selected|login=1191180|account=RUBRI1|sip=192.168.0.22|UserName=Rick Rubner|group=3|responsecode=0|result=|dname=USDF11V0835\LTEPICPR|sessiontype=|vendorinfo=LTEPIC
\|\s+(?<sip>[^ ]*)\s+\|\s+(?<login>[^ ]*)\s+\|\s+(?<action>[^|]*)\s+\|\s+(?<vendorinfo>[^ ]*)$
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)