#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).*[0-9].*[|][0-9]{2}.[0-9]{2}.[0-9]{4}.*"
Local $sString = "|Sort criteria|Ascdg|Descending|Subtotal|" & @CRLF & _
"|---------------------------------------|" & @CRLF & _
"|Number Group | X | | X |" & @CRLF & _
"|Document type| X | | X |" & @CRLF & _
"-----------------------------------------" & @CRLF & _
"---------------------------" & @CRLF & _
"|Data statistics|Number of|" & @CRLF & _
"|-------------------------|" & @CRLF & _
"|Records passed | 638,705|" & @CRLF & _
"---------------------------" & @CRLF & _
"----------------------" & @CRLF & _
"| CoCode|Prod.Month |" & @CRLF & _
"|---------------------" & @CRLF & _
"| 1002 |31.12.2020 |" & @CRLF & _
"| 1002 |31.12.2020 |" & @CRLF & _
"| 1002 |31.12.2020 |" & @CRLF & _
"| 1002 |31.12.2020 |" & @CRLF & _
"| 1002 |31.12.2020 |" & @CRLF & _
"----------------------" & @CRLF & _
"----------------------" & @CRLF & _
"| CoCode|Prod.Month |" & @CRLF & _
"|---------------------" & @CRLF & _
"| 1002 |31.07.2020 |" & @CRLF & _
"| 1002 |31.07.2020 |" & @CRLF & _
"| 1002 |31.07.2020 |" & @CRLF & _
"----------------------"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")