re = /.*[0-9].*[|][0-9]{2}.[0-9]{2}.[0-9]{4}.*/m
str = '|Sort criteria|Ascdg|Descending|Subtotal|
|---------------------------------------|
|Number Group | X | | X |
|Document type| X | | X |
-----------------------------------------
---------------------------
|Data statistics|Number of|
|-------------------------|
|Records passed | 638,705|
---------------------------
----------------------
| CoCode|Prod.Month |
|---------------------
| 1002 |31.12.2020 |
| 1002 |31.12.2020 |
| 1002 |31.12.2020 |
| 1002 |31.12.2020 |
| 1002 |31.12.2020 |
----------------------
----------------------
| CoCode|Prod.Month |
|---------------------
| 1002 |31.07.2020 |
| 1002 |31.07.2020 |
| 1002 |31.07.2020 |
----------------------'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end