// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m).*[0-9].*[|][0-9]{2}.[0-9]{2}.[0-9]{4}.*").unwrap();
let string = "|Sort criteria|Ascdg|Descending|Subtotal|
|---------------------------------------|
|Number Group | X | | X |
|Document type| X | | X |
-----------------------------------------
---------------------------
|Data statistics|Number of|
|-------------------------|
|Records passed | 638,705|
---------------------------
----------------------
| CoCode|Prod.Month |
|---------------------
| 1002 |31.12.2020 |
| 1002 |31.12.2020 |
| 1002 |31.12.2020 |
| 1002 |31.12.2020 |
| 1002 |31.12.2020 |
----------------------
----------------------
| CoCode|Prod.Month |
|---------------------
| 1002 |31.07.2020 |
| 1002 |31.07.2020 |
| 1002 |31.07.2020 |
----------------------";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}