#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[\d_-]*[a-zA-Z][-\w]*$"
Local $sString = "ecK3EnyGD8o" & @CRLF & _
"1s3get2-3ds" & @CRLF & _
"4bc2qfs2wrf" & @CRLF & _
"28yq389gfwg" & @CRLF & _
"3oyh8pw489p" & @CRLF & _
"abcdefghijk" & @CRLF & _
"abcde-fghi_jk" & @CRLF & _
"12345678910" & @CRLF & _
"18974107892351240891751928347819234" & @CRLF & _
"Stack Overflow" & @CRLF & _
"kjsad;kflj;klasdfkjalk;sdfjlkas" & @CRLF & _
"!&$@#)&&()%&*(#@$&("
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")