// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[\d_-]*[a-zA-Z][-\w]*$").unwrap();
let string = "ecK3EnyGD8o
1s3get2-3ds
4bc2qfs2wrf
28yq389gfwg
3oyh8pw489p
abcdefghijk
abcde-fghi_jk
12345678910
18974107892351240891751928347819234
Stack Overflow
kjsad;kflj;klasdfkjalk;sdfjlkas
!&$@#)&&()%&*(#@$&(";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}